RSS

linux-3.7に上げようとしたが…

Debianにlinux-3.7.1が入ったので(experimental)入れようとする。いつものようにlinux-kbuild-*がないのでlinux-headers-*が入らないからdkmsのモジュールがコンパイルできないんだよなーと調べてみると…。kernelだけあってlinux-kbuildがないというのはどういうことだと前から思っていたので調べてみると同じ文句をBTS言っている人が。しかもGraveになってる。linux側かlinux-tools側のどっちの責任か知らんが自分でlinux-kbuildを作る方法のドキュメントがあった。ひどいなあ…。

ドキュメントを見ながら自分でlinux-kbuild-3.7を作成。ここは問題なかったが。いざfglrxのモジュールを作ろうとするとエラーが。asm-generic/types.hがないと言っている。おや? 以前のバージョンにはあるが…。なんか変わったのか。Debian側の問題なのか?よくわからん。調べている過程で他の問題もあってfglrxのソースにパッチが必要とか…。面倒くさくなって挫折。